PHP versiunea 5.4

ClausWeb trece progresiv pe PHP 5.4

La nivel mondial, toti proprietarii de servere de shared hosting (si nu numai) vor face trecerea la PHP 5.4 si ulterior la PHP 5.5, in viitorul foarte apropiat. Acest lucru se intampla din cauza ca versiunile vechi de PHP nu mai sunt intretinute (PHP 5.3 nu mai este dezvoltat din luna martie a anului 2013) si contin numeroase vulnerabilitati. De asemenea, versiunile noi de PHP contin numeroase functii noi, de care dorim sa puteti beneficia dupa bunul plac, cat mai curand. Deoarece punem securitatea pe primul loc si dorim mereu sa beneficiati de cea mai buna calitate a serviciilor de hosting, vom face trecerea progresiv la PHP 5.4.

 

Pentru a putea sa va faceti o imagine cat mai clara asupra noutatilor din PHP 5.4, va invitam sa alocati cateva minute pentru a studia documentatia oficiala la http://php.net/releases/5_4_0.php
De asemenea, mai aveti disponibile doua ghiduri oficiale pentru migrarea de la PHP 5.2 la 5.3 la 5.4 :
Migrare PHP 5.3 > 5.4: http://www.php.net/manual/ro/migration54.php
Migrare PHP 5.2 > 5.3: http://ro1.php.net/manual/ro/migration53.php

Un alt document foarte folositor este cel care cuprinde lista de incompatibilitati – http://www.php.net/manual/en/migration54.incompatible.php

Exista cateva functii care au fost eliminate in versiunea 5.4 PHP, care pot influenta functionalitatea unor siteuri. Am incercat sa le sumarizam pe cele mai importante mai jos, pentru a le putea identifica mai usor cand verificati functionalitatea pe noul PHP :

Directive eliminate : register_globals, magic_quotes, safe_mode, call-time pass by reference, import_request_variables(), session_register() si session_unregister()

Functii invechite : mcrypt_generic_end() inlocuit cu mcrypt_generic_deinit() si mysql_list_dbs() – se pot utiliza functii similare MySQLi sau pdo_MySQL

Pentru CMS-urile open-source de tip WordPress sau Joomla actualizate la zi nu exista probleme de compatibilitate. Din pacate, nu se poate spune acelasi lucru despre platformele neactualizate.

WordPress este cel mai permisiv, din acest punct de vedere. Versiunile mai noi de 3.2 sunt compatibile cu PHP 5.4, iar versiunile mai vechi ruleaza cu afisarea unor erori. Daca experimentati probleme cu pluginurile folosite pe un site WordPress, va trebui sa va adresati producatorului pentru a afla daca acesta va fi actualizat pentru PHP 5.4.

Joomla! – versiunile 2.5 si 3 sunt compatibile cu PHP 5.4, dar orice sub acestea nu este (Joomla! 1.5, 1.6 sau 1.7) – http://docs.joomla.org/Joomla_1.5_won%27t_work_on_PHP_5.4

Dintre cele mai folosite platforme de eCommerce, PrestaShop functioneaza pe versiunile mai noi de 1.5, Magento pe cele mai noi de 1.7, openCart incepand cu 1.5.6, iar Zencart incepand cu 1.5. Pentru orice alte scripturi sau CMS-uri, va recomandam sa consultati pagina de support a producatorului.

Lasă un răspuns

Acest sit folosește Akismet pentru a reduce spamul. Află cum sunt procesate datele comentariilor tale.